02-线性结构4 Pop Sequence (25分)

02-线性结构4 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

实现一个栈的数据结构,用数组和一个下标来模拟。判断是否会出现堆栈爆满的情况。

#include <stdio.h>

#define MAXVAL 1000

static int sp = 0;
static int val[MAXVAL];

int push(int i, int M)
{
    int ret = 0;
    if (sp < M) {
        val[sp++] = i;
    }
    else {
        ret = -1;
    }
    return ret;
}

int pop(void)
{
    return sp > 0 ? val[--sp] : 0;
}

int get_top(void)
{
    return sp > 0 ? val[sp - 1] : 0;
}

int main(int argc, char const *argv[])
{
    int M, N, K;

    scanf("%d %d %d", &M, &N, &K);

    while (K--) {
        sp = 0;
        int line[N];
        for (int i = 0; i < N; i++) {
            scanf("%d", &line[i]);
        }
        int index = 0, x = 2;

        push(1, M);
        int ok = 1;
        while (index < sizeof(line) / sizeof(line[0])) {
            int top = get_top();
            if (top == line[index]) {
                pop();
                index++;
            }
            else if (push(x++, M) < 0) {
                ok = 0;
                break;
            }
        }
        if (ok) {
            printf("YES\n");
        }
        else {
            printf("NO\n");
        }
    }
    return 0;
}

posted @ 2020-03-20 15:10  wngtk  阅读(223)  评论(0编辑  收藏  举报