poj 1651 Multiplication Puzzle(区间dp)

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6

10 1 50 50 20 5

Sample Output

3650

 

题意:已知一行数字 现在问你除两端的数字不能抽取以外没,每次抽取一个数字的花费都是当前数字的权值分别乘上两边数字的权值 问最小花费是多少

思路:我们不妨设dp[][]表示区间 i~j 中数字抽取的最小花费(i和j不能取)这样我们不难推出方程dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[i]*a[k]*a[j]);

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int dp[107][107];
int a[107];
int main(){
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n){
        memset(dp,inf,sizeof(dp));
        for(int i=1;i<=n;i++)
            cin>>a[i];
        for(int i=1;i<=n;i++){ //初始化 长度为1和2的区间都是不能合并的 花费为0 
            dp[i][i]=0;
            dp[i][i+1]=0;
        }
        for(int len=3;len<=n;len++){
            for(int i=1;i+len<=n+1;i++){
                int j=i+len-1;
                for(int k=i+1;k<j;k++)
                    dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[i]*a[k]*a[j]);    
            }
            
        }
        cout<<dp[1][n]<<endl;
    }
    return 0;
}

 

posted @ 2019-04-14 14:25  WAKBGAN  阅读(135)  评论(0编辑  收藏  举报