HDU-5391-Zball in Tina Town

Problem Description

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

Input

The first line of input contains an integer T, representing the number of cases.
The following T lines, each line contains an integer n, according to the description.
T≤105,2≤n≤109

Output

For each test case, output an integer representing the answer.

Sample Input

2
3
10


Sample Output

2
0

Source

BestCoder Round #51 (div.2)



--------------------------------------------并不华丽的分界线-----------------------------------

这道题其实还是比较水的。。。

题目大意:Tina有一个很神奇的球,这个球每天都会变大,而且第n天球的体积是第n-1天的n倍,问你球第n-1天的时候体积对n取模的值

看到这道题,我们第一个想法必然是求(n-1)! % n,但是很明显,这道题10^9的数据绝对不能用n!来写,且不说空间问题,即使是时间也会爆掉的。那么不难想到,既然不能直接搞暴力,那么必然是有一个规律来解决这个问题。那么是什么规律呢?

我们把2-20的数据列出来:

n 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
ans 1 2 2 4 0 6 0 0 0 10 0 12 0 0 0 16 0 18 0
看到这里我们可以很明显的发现规律了。也就是当n为质数时,(n-1)! % n解为n-1,当n为合数的时候,(n-1)! % n的解为0

但是为什么会有这个解呢?

我相信很多人在想到这里之后就会直接跳过了,但是仔细思考一下,可能会有很多好的效果。

证明就不说了。

在求n是否为素数的时候可以使用Miller-Rabin算法,也可以直接朴素的搞。

值得说的是,可以不必用i <= sqrt(n) 而是使用i * i <= n

另外在朴素的搞的时候,会发现如果使用long long的话,可能会超时,个人认为是因为64位使用的CPU寄存器数量比32位使用的寄存器多,运算更加复杂造成了这个现象。

下面贴代码

#include <stdio.h>
int main()
{
    int t;
    scanf("%d", &t);
    while(t--){
        int i, n;
        int flag = 1;
        scanf("%d", &n);
        for(i = 2; i *i <= n; ++i){
            if(!(n % i)){
                flag = 0;
                break;
            }
        }
        if(n == 4){
            printf("2\n");
        }else if(flag){
            printf("%d\n", n-1);
        }else{
            printf("0\n");
        }
    }  
    return 0;
}


这几天看到一个定理叫做威尔逊定理,发现这道题就是威尔逊定理的应用。

威尔逊定理是说,当n为质数的时候,n可以整除(n-1)! + 1

对应这题来说,n可以整除 (n-1)! + 1, 也就是说,(n-1)! mod n = n - 1

posted @ 2015-08-22 17:36  _Wilbert  阅读(103)  评论(0编辑  收藏  举报