PAT 1004 成绩排名

PAT 1004 成绩排名

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

 思路:简单的比大小,输入时就进行判断,记录最高成绩最低成绩的编号,直接输出即可。这里我踩了个坑wa了一发。萌新总想着给编译器省点内存,在声明结构体时,结构体数组使用的太小,出现了段错误,orz。代码如下:

#include <iostream>
#include <math.h>
#include <cstdlib>
#include <cstdio>
#include <cctype>
#include <algorithm>
#include <queue>
#include <vector>
#include <string>
#include <sstream>
#include <set>
#include <stack>
#include <map>
#include <utility>
#define LL long long
const int max_n=200;//第一发就wa在这里了,qaq
using namespace std;
struct node{
	string x,y;
	int n;
}num[max_n];
int main()
{
	int n;
	int mx=0,mi=100,mxnum=-1,minum=-1;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		cin>>num[i].x>>num[i].y >>num[i].n;
		if(num[i].n<0||num[i].n>100)break;
		if(num[i].n>mx)mx=num[i].n,mxnum=i;
		if(num[i].n<mi)mi=num[i].n,minum=i;
	}
	cout<<num[mxnum].x<<" "<<num[mxnum].y<<endl;
	cout<<num[minum].x<<" "<<num[minum].y<<endl;
	return 0;
}

 

posted @ 2019-07-30 16:58  whocarethat  阅读(85)  评论(0编辑  收藏  举报