PAT 1008数组元素右移问题

PAT 1008数组元素右移问题

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A​0​​A​1​​⋯A​N−1​​)变换为(A​N−M​​⋯A​N−1​​A​0​​A​1​​⋯A​N−M−1​​)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:

每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。

输出格式:

在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4

 思路:使用双端队列,将队尾元素插入队首,然后删除队尾元素即可。代码如下:

#include <iostream>
#include <math.h>
#include <cstdlib>
#include <cstdio>
#include <cctype>
#include <algorithm>
#include <queue>
#include <vector>
#include <string>
#include <sstream>
#include <set>
#include <stack>
#include <map>
#include <utility>
#define LL long long
using namespace std;
int main()
{
	deque<int> d;
	int n,k,x;
	cin>>n>>k;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&x);
		d.push_back(x);
	}
	if(k>n)k=k%n;
	for(int i=0;i<k;i++){
		x=d[n-1];
		d.pop_back();
		d.push_front(x);
	}
	for(int i=0;i<n;i++){
		if(i!=0)printf(" ");
		printf("%d",d[i]);
	}
	return 0;
}

 

posted @ 2019-08-03 20:14  whocarethat  阅读(81)  评论(0编辑  收藏  举报