PAT 1020 月饼

PAT 1020 月饼

 

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例: 

94.50

 思路:结构体排序,根据输入的信息,将不同种类的月饼按照单价从高到低排序,然后贪心选取单价高的月饼即可。注意段错误的发生,不能访问到非法内存中。代码如下:

#include <iostream>
#include <math.h>
#include <cstdlib>
#include <cstdio>
#include <cctype>
#include <algorithm>
#include <queue>
#include <vector>
#include <string>
#include <sstream>
#include <set>
#include <stack>
#include <map>
#include <utility>
#define LL long long
using namespace std;
struct node{
	double m,w;
	double v;
}s[1003];
bool cmp(node a,node b)
{
	if(a.v==b.v)return a.m>b.m;
	return a.v>b.v;
}
int main()
{
	int a,b;
	scanf("%d %d",&a,&b);
	for(int i=0;i<a;i++)cin>>s[i].m;
	for(int i=0;i<a;i++)cin>>s[i].w;
	for(int i=0;i<a;i++)s[i].v=double(s[i].w)/double(s[i].m);
	sort(s,s+a,cmp);
	double sum=0.00;
	int x=0;
	while(b>0){
		if(b>=s[x].m){b-=s[x].m;sum+=s[x].w;}
		else{
			sum+=b*s[x].v;
			b=0;
		}
		x++;
		if(x==a)break;//这里可能会引起段错误。
	}
	printf("%.2f\n",sum);
	return 0;
}

 

posted @ 2019-08-05 21:04  whocarethat  阅读(64)  评论(0编辑  收藏  举报