Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
  题目大意:给你一个正整数n,请编写一个程序寻找n的非零倍数m,m仅由数字0和1构成,假定n不大于200且m不多于100位。
  提示:本题采用Special Judge,你无需输出所有符合条件的 m,只需输出ren任一符合条件的m即可。多组输入,每次 输入仅一行,输出也仅一行。
  思路:可以看做由数字1开始,每次乘10或者乘10加一,进行递归,直到某个仅由0、1构成的数是n的倍数时,输出该数。代码如下:
#include <iostream>
using namespace std;
int solve,n;
void dfs(unsigned long long num,int k)
{
    if(solve==1)return ;
    if(num%n==0)
    {
        solve=1;//判断条件变化
        cout<<num<<endl;
    }
    if(k==19)return ;//避免数据溢出
    dfs(num*10,k+1);
    dfs(num*10+1,k+1);
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        if(n==0)break;
        solve=0;
        dfs(1,0);
    }
    return 0;
}

 

 
posted @ 2019-07-02 10:15  whocarethat  阅读(141)  评论(0编辑  收藏  举报