1961 Period

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

 
题意:给你一个字符串,求这个字符串到第i个字符为止的循环节的次数。

比如aabaabaabaab,长度为12.到第二个a时,a出现2次,输出2.到第二个b时,aab出现了2次,输出2.到第三个b时,aab出现3次,输出3.到第四个b时,aab出现4次,输出4.

思路:这道题好像就是POJ 2406的加强版而已。那道题是输出一个字符串的循环节出现的次数,这个是到第i个字符为止,其实就是多了一层循环。把这个字符串遍历一次即可。

 

#include<cstdio>
#include<iostream>
#define MAXN 1000010
using namespace std;
char s[MAXN];
int next[MAXN],len,t;
inline void go() {
    int p=-1,i=0;
    next[0]=-1;
    while(i!=len) {
        if(p==-1||s[i]==s[p]) next[++i]=++p;
        else p=next[p];
    }
}
int main() {
    while(scanf("%d",&len)&&len) {
        scanf("%s",s);
        go();
        t++;
        printf("Test case #%d\n",t);
        for(int i=1;i<=len;i++) {
            int l=i-next[i];
            if(i!=l&&i%l==0)
              printf("%d %d\n",i,i/l);
        }
        printf("\n");
    }
    return 0;
}
View Code

 

posted @ 2017-02-08 10:50  拿叉插猹哈  阅读(170)  评论(0编辑  收藏  举报