hdu 2669

Description

The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input

The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input

77 51 10 44 34 79
 

Sample Output

2 -3
sorry
7 -3 
题意:
前面一大段话都是废话。不要看就好了,题目的意思是给你两个正整数a,b,yaoni 要你求出一个正整数X和一个整数Y使得X*a+Y *b=1;假设这样的情况不存在,输出sorry,假设存在,输出最小的X。
思路:
这是一道扩展欧几里得算法题,我看了一下算法竞赛与入门经典中的P313。书上讲了一个类似的题目,还有參考了一个专门讲扩展欧几里得算法的博客,地址http://www.cnblogs.com/yuelingzhi/archive/2011/08/13/2137582.html ,看了看,看出一点名堂了,然后把代码贴上去KO了。

代码:
#include<cstdio>
using namespace std;
int exgcd(int a,int b,int &x,int &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    int  r=exgcd(b,a%b,x,y);
    int t=x;
    x=y;
    y=t-a/b*y;
    return r;
}
int main()
{
    int a,b,x,y,m;
    while(scanf("%d%d",&a,&b)!=EOF)
    {

        m=exgcd(a,b,x,y);
        if(m==1)
        {
            while(x<0)
            {
                x+=b;
                y-=a;
            }
            printf("%d %d\n",x,y);
        }

        else
            printf("sorry\n");
    }
    return 0;
}



posted on 2017-07-12 21:36  wgwyanfs  阅读(215)  评论(0编辑  收藏  举报

导航