ACM MST Connect the Cities

Connect the Cities
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input

1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output

1
 
 
好奇怪,g++交TLE了,c++叫过了
 
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

int t,n,m,k,sum;
int father[505];
struct Road
{
    int a,b,value;
} road[30000];
int find(int x)
{
    if(x!=father[x])
        father[x]=find(father[x]);
    return father[x];
}
void merge(int x,int y,int z,int &tp)
{
    int a,b;
    a=find(x);
    b=find(y);
    if(a!=b)
    {
        tp+=z;
        father[a]=b;
    }
}

bool cmp(const Road &a,const Road &b)
{
    return a.value<b.value;
}



int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d %d",&road[i].a,&road[i].b,&road[i].value);
        }
        int tt,tmp,x,y;
        int cnt = m;
        while(k--)
        {
            scanf("%d%d",&tt,&x);
            while(--tt)
            {
                scanf("%d",&y);
                road[++cnt].a = x;
                road[cnt].b = y;
                road[cnt].value = 0;;
                x=y;
            }
        }
        sum = 0;
        sort(road+1,road+cnt+1,cmp);
//        for(int i=1; i<=cnt; i++)
//            printf("%d %d %d\n",road[i].a,road[i].b,road[i].value);
        for(int i=1;i<=n;i++)
            father[i]=i;
        for (int i=1;i<=cnt;i++)
        {
            merge(road[i].a,road[i].b,road[i].value,sum);
        }
        int mother[505];
        for(int i=1; i<=n; i++)
        {
            mother[i] = find(i);
        }
        bool ok = 1;
        for(int i = 1; i<n; i++)
        {
            if(mother[i]!=mother[i+1])
            {
                ok=0;
                break;
            }
        }
        if(ok)
            printf("%d\n",sum);
        else
            printf("-1\n");
    }
}

  

posted @ 2013-08-16 13:17  围剿大叔  阅读(220)  评论(0编辑  收藏  举报