Values whose Sum is 0

专题二(分治)
131:19:34
725:00:00
        
D - 4 Values whose Sum is 0
Time Limit:15000MS     Memory Limit:228000KB     64bit IO Format:%I64d & %I64u

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


#include <iostream>
#include <numeric>
#include <algorithm>
#include <cstdio>
using namespace std;

int main()
{
    int n, m;
    int day[100050];

    scanf("%d %d", &n, &m);
    int max_money = 0, min_money = 0;

    for(int i = 0; i < n; ++i)
    {
        scanf("%d", &day[i]);
        max_money +=day[i];
        if(day[i] > min_money)
        {
            min_money = day[i];
        }
    }

    int mid = max_money + min_money;

    while(min_money < max_money)
    {
        mid = (min_money + max_money) / 2;
        int k = 0;
        int sum = 0;
        for (int i = 0; i < n; i++)
        {
            sum += day[i];
            if (sum > mid)
            {
                sum = day[i];
                k++;
            }
        }

        if (k < m) max_money = mid;
        else min_money = mid + 1;
    }

    printf("%d",max_money);
    return 0;
}

还是二分,最大值是每天的和,最小值就是钱最多的那天,然后通过二分,看M是否符合要求,就这样,继续下一道了
posted @ 2013-07-18 10:24  围剿大叔  阅读(196)  评论(0编辑  收藏  举报