hdu 4004 The Frog's Games

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 2861    Accepted Submission(s): 1431


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

 
Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m.
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

 
Output
For each case, output a integer standing for the frog's ability at least they should have.
 

 
Sample Input
6 1 2
2
25 3 3
11
2
18
 

 
Sample Output
4
11
 
题意:青蛙过河,河中间有一堆石子,限定跳的次数,求最短跳的距离
 
连续二分
先二分枚举跳的距离,里面再二分数跳的次数,二分的力量。。。。。
 
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#define maxn 500100
#define INF 1000000000
#define min(a, b) a < b ? a : b
using namespace std;
 
int a[maxn], n, m;
 
int binary( int dis ){
    int cnt = 0;
    int * i = a;
    while ( i < a+n ){
        int * j = lower_bound(a, a+n, *i+dis);
        if ( *i+dis < *j ){
            j--;
        }
        i = j;
        cnt++;
        if ( cnt > m ){
            return 0;
        }
    }
    return 1;
}
 
int main(){
    int dis;
    while ( ~scanf("%d%d%d", &dis, &n, &m) ){
        for ( int i = 1; i <= n; i++ ){
            scanf("%d", &a[i]);
        }
        a[0] = 0;
        a[++n] = dis;
        sort( a, a+n );
        int low = 0, high = dis;
        for ( i = 1; i <= n; i++ ){
            if ( high < a[i] - a[i-1] ){
                high = a[i] - a[i-1];
            }
        }
 
        //while ( low <= high ){                --两种二分
        while ( low < high ){
            int mid = ( low + high ) >> 1;
            int ans = binary( mid );
            //if ( !ans ){
            //    low = mid + 1;
            if ( ans ){
                high = mid;
            }
            else{
                low = mid + 1;
            }
        }
        printf("%d\n", high);
        //printf("%d\n", low);
    }
    return 0;
}
 
posted @ 2013-10-22 12:10  /bin  阅读(200)  评论(0编辑  收藏  举报