Problem Description
多项式的描述如下:
1 - 1/2 + 1/3 - 1/4 + 1/5 - 1/6 + …
现在请你求出该多项式的前n项的和。

Input
输入数据由2行组成,首先是一个正整数m(m<100),表示测试实例的个数,第二行包含m个正整数,对于每一个整数(不妨设为n,n<1000),求该多项式的前n项的和。

Output
对于每个测试实例n,要求输出多项式前n项的和。每个测试实例的输出占一行,结果保留2位小数。

Sample Input
2
1 2

Sample Output
1.00
0.50

import java.util.Scanner;
class Main{
   public static void main(String args[]){
      Scanner sc = new Scanner(System.in);
      int n = sc.nextInt();
      while(n-->0){
          int m = sc.nextInt();
          double s = 0;
          int flag = 1;//利用flag来改变正负号
          for(int i=1;i<=m;i++){
              s+=(double)(flag*(1.0/i));
              //System.err.printf("%.2f",s);
              flag=-flag;//改变符号
          }
          System.err.printf("%.2f",s);
          System.err.println();
      }
   }
}
posted on 2015-11-06 19:08  cnxo  阅读(112)  评论(0编辑  收藏  举报