(最小生成树)hdu 3371

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12557    Accepted Submission(s): 3453


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

 

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

 

Sample Output
1
 

 

Author
dandelion
 
 
有些边已经联通,有些边还未联通。。。
不知道为嘛超时啊啊啊啊啊啊啊啊啊啊啊啊啊
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<vector>
using namespace std;
struct node
{
    int x,y,w;
}e[25005];
int n,m,k,cnt,fa[25005];
/*
int find(int x)
{
    if(x!=fa[x])
        fa[x]=find(fa[x]);
    return fa[x];
}
*/
int find(int x)
{
    while(x!=fa[x])
        x=fa[x];
    return fa[x];
}
int Union(int x,int y)
{
    if(x==-1)
        return 0;
    int fx,fy;
    bool flag=false;
    fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        --cnt;
        fa[fx]=fy;
        flag=1;
    }
    return flag;
}
bool cmp(node a,node b)
{
    return a.w<b.w;
}
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        int ans=0;
        scanf("%d%d%d",&n,&m,&k);
        cnt=n-1;
        for(int i=0;i<=n;i++)
            fa[i]=i;
        for(int i=1;i<=m;i++)
            scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].w);
        for(int i=0;i<k;i++)
        {
            int a,c,pre=-1;
            scanf("%d",&a);
            while(a--)
            {
                scanf("%d",&c);
                Union(pre,c);
                pre=c;
            }
        }
        sort(e+1,e+1+m,cmp);
        for(int i=1;i<=m;i++)
        {
            if(Union(e[i].x,e[i].y)==1)
                ans+=e[i].w;
        }
        if(cnt!=0)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}

  

posted @ 2015-05-17 16:46  waterfull  阅读(123)  评论(0编辑  收藏  举报