(拓扑图+DP) poj 3249

Test for Job
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9563   Accepted: 2201

Description

Mr.Dog was fired by his company. In order to support his family, he must find a new job as soon as possible. Nowadays, It's hard to have a job, since there are swelling numbers of the unemployed. So some companies often use hard tests for their recruitment.

The test is like this: starting from a source-city, you may pass through some directed roads to reach another city. Each time you reach a city, you can earn some profit or pay some fee, Let this process continue until you reach a target-city. The boss will compute the expense you spent for your trip and the profit you have just obtained. Finally, he will decide whether you can be hired.

In order to get the job, Mr.Dog managed to obtain the knowledge of the net profit Vi of all cities he may reach (a negative Vi indicates that money is spent rather than gained) and the connection between cities. A city with no roads leading to it is a source-city and a city with no roads leading to other cities is a target-city. The mission of Mr.Dog is to start from a source-city and choose a route leading to a target-city through which he can get the maximum profit.

Input

The input file includes several test cases. 
The first line of each test case contains 2 integers n and m(1 ≤ n ≤ 100000, 0 ≤ m ≤ 1000000) indicating the number of cities and roads. 
The next n lines each contain a single integer. The ith line describes the net profit of the city iVi (0 ≤ |Vi| ≤ 20000) 
The next m lines each contain two integers xy indicating that there is a road leads from city x to city y. It is guaranteed that each road appears exactly once, and there is no way to return to a previous city. 

Output

The output file contains one line for each test cases, in which contains an integer indicating the maximum profit Dog is able to obtain (or the minimum expenditure to spend)

Sample Input

6 5
1
2
2
3
3
4
1 2
1 3
2 4
3 4
5 6

Sample Output

7

Hint

Source

 
题意 
每个点都有权值,然后求 入度为0到出度为0的一条路径,使得权值和最大
 
显然拓扑排序然后 dp搞就行了啊
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<string>
#define INF 100000000
using namespace std;
vector<int> e[100005];
int num[100005],n,m,in[100005],dp[100005],ans;
void topsort()
{
    queue<int> q;
    for(int i=1;i<=n;i++)
    {
        if(in[i]==0)
        {
            q.push(i);
            dp[i]=num[i];
        }
    }
    while(!q.empty())
    {
        int x;
        x=q.front();
        q.pop();
        bool flag=true;
        for(int i=0;i<e[x].size();i++)
        {
            flag=false;
            int v=e[x][i];
            dp[v]=max(dp[v],dp[x]+num[v]);
            if(--in[v]==0)
            {
                q.push(v);
            }
        }
        if(flag&&dp[x]>ans)
            ans=dp[x];
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=-INF;
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]),e[i].clear(),dp[i]=-INF,in[i]=0;
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            e[x].push_back(y);
            in[y]++;
        }
        topsort();
        printf("%d\n",ans);
    }
    return 0;
}

  

posted @ 2015-05-13 15:59  waterfull  阅读(175)  评论(0编辑  收藏  举报