(floyd+补集) poj 3275

Ranking the Cows
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 2569   Accepted: 1203

Description

Each of Farmer John's N cows (1 ≤ N ≤ 1,000) produces milk at a different positive rate, and FJ would like to order his cows according to these rates from the fastest milk producer to the slowest.

FJ has already compared the milk output rate for M (1 ≤ M ≤ 10,000) pairs of cows. He wants to make a list of C additional pairs of cows such that, if he now compares those C pairs, he will definitely be able to deduce the correct ordering of all N cows. Please help him determine the minimum value of C for which such a list is possible.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..M+1: Two space-separated integers, respectively: X and Y. Both X and Y are in the range 1...N and describe a comparison where cow X was ranked higher than cow Y.

Output

Line 1: A single integer that is the minimum value of C.

Sample Input

5 5
2 1
1 5
2 3
1 4
3 4

Sample Output

3

Hint

From the information in the 5 test results, Farmer John knows that since cow 2 > cow 1 > cow 5 and cow 2 > cow 3 > cow 4, cow 2 has the highest rank. However, he needs to know whether cow 1 > cow 3 to determine the cow with the second highest rank. Also, he will need one more question to determine the ordering between cow 4 and cow 5. After that, he will need to know if cow 5 > cow 3 if cow 1 has higher rank than cow 3. He will have to ask three questions in order to be sure he has the rankings: "Is cow 1 > cow 3? Is cow 4 > cow 5? Is cow 5 > cow 3?"

Source

 
题意。。。给出若干大小,求还需要多少对比较使得构成一个顺序。。
补集的思想。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<vector>
using namespace std;
vector<int> from[1001],to[1001];
int mp[1001][1001];
int n,m;
int main()
{
    int ans=0;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        mp[x][y]=1;
        from[x].push_back(y);
        to[y].push_back(x);
    }
    for(int k=1;k<=n;k++)
    {
        for(int i=0;i<to[k].size();i++)
        {
            for(int j=0;j<from[k].size();j++)
            {
                int x,y;
                x=to[k][i],y=from[k][j];
                if(!mp[x][y])
                {
                    mp[x][y]=1;
                    from[x].push_back(y);
                    to[y].push_back(x);
                }
            }
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(i!=j&&mp[i][j])
                ans++;
        }
    }
    printf("%d\n",n*(n-1)/2-ans);
    return 0;
}

  

posted @ 2015-05-03 18:06  waterfull  阅读(137)  评论(0编辑  收藏  举报