(hash) hdu 1496

Equations

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6089    Accepted Submission(s): 2465


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

 

Output
For each test case, output a single line containing the number of the solutions.
 

 

Sample Input
1 2 3 -4 1 1 1 1
 

 

Sample Output
39088 0
 

 

Author
LL
 

 

Source
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
using namespace std;
int hash1[1000005],hash2[5000005];
int a,b,c,d;
int main()
{
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {
        int ans=0,temp;
        if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
        {
            printf("0\n");
            continue;
        }
        for(int i=0;i<1000005;i++)
            hash1[i]=hash2[i]=0;
        for(int i=1;i<=100;i++)
        {
            for(int j=1;j<=100;j++)
            {
                temp=a*i*i+b*j*j;
                //printf("%d\n",temp);
                if(temp>=0)
                    hash1[temp]++;
                else
                    hash2[-temp]++;
            }
        }
        for(int i=1;i<=100;i++)
        {
            for(int j=1;j<=100;j++)
            {
                temp=c*i*i+d*j*j;
                if(temp>0)
                    ans+=hash2[temp];
                else
                    ans+=hash1[-temp];
            }
            //printf("%d\n",ans);
        }
        printf("%d\n",16*ans);
    }
    return 0;
}

  

posted @ 2015-05-03 11:39  waterfull  阅读(103)  评论(0编辑  收藏  举报