(01染色判断奇环+匈牙利算法) hdu 2444

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3041    Accepted Submission(s): 1424


Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

 

Sample Input
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

 

Sample Output
No 3
 

 

Source
 
直接染色判断奇环
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
int n,m,mp[205][205],col[205],link[205],mark[205];
bool dfs1(int x,int flag)
{
    for(int i=1;i<=n;i++)
    {
        if(mp[x][i])
        {
            if(col[i]==-1)
            {
                col[i]=!flag;
                if(!dfs1(i,col[i]))
                    return false;
            }
            else if(col[i]==flag)
                return false;
        }
    }
    return true;
}
bool dfs2(int x)
{
    for(int i=1;i<=n;i++)
    {
        if(mp[x][i]&&mark[i]==-1)
        {
            mark[i]=1;
            if(link[i]==-1||dfs2(link[i]))
            {
                link[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int x,y;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        bool flag=true;
        memset(mp,0,sizeof(mp));
        memset(col,-1,sizeof(col));
        memset(link,-1,sizeof(link));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            mp[x][y]=mp[y][x]=1;
        }
        for(int i=1;i<=n;i++)
        {
            if(col[i]==-1)
            {
                col[i]=0;
                if(!dfs1(i,col[i]))
                {
                    flag=false;
                    break;
                }
            }
        }
        if(!flag)
        {
            printf("No\n");
            continue;
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            memset(mark,-1,sizeof(mark));
            if(dfs2(i))
                ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}

  

posted @ 2015-04-27 10:56  waterfull  阅读(159)  评论(0编辑  收藏  举报