HDU 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9899    Accepted Submission(s): 4518


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 
Kmp:
 
 
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#define MAXN 1000010
int T[MAXN], P[MAXN/10], fail[MAXN/10], N, M;
void getFail(){
    fail[0] = -1;
    for(int i = 1, j = -1;i < M;i ++){
        while(P[i] != P[j+1] && j >= 0) j = fail[j];
        if(P[i] == P[j+1]) j++;
        fail[i] = j;
    }
}
void Kmp(){
    getFail();
    for(int i = 0, j = 0;i < N;i ++){
        while(T[i] != P[j] && j) j = fail[j-1] + 1;
        if(T[i] == P[j]) j++;
        if(j == M){
            printf("%d\n", i-M+2);
            return;
        }
    }
    printf("-1\n");
}
int main(){
    int t;
    /* freopen("in.c", "r", stdin); */
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &N, &M);
        for(int i = 0;i < N;i ++) scanf("%d", T+i);
        for(int i = 0;i < M;i ++) scanf("%d", P+i);
        Kmp();
    }
    return 0;
}

 
posted on 2014-04-30 18:39  wangzhili  阅读(79)  评论(0编辑  收藏  举报