hdu1597

Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output
对于每个N,输出S中第N个对应的数字.
 

Sample Input
6 1 2 3 4 5 10
 

Sample Output
1 1 2 1 2 4

第一次用二分法做出题来,太开心了,虽然这个简单;

#include <iostream>
#include <cmath>
using namespace std;
__int64 a[65540],i;
int main(){
	
	int cmp(int,int,int);
	a[0]=0;
	for(i=1;i<65537;i++)
	  {
	  	a[i]=a[i-1]+i;
	  }
    __int64 b,c,n,m,k,j;
    cin>>n;
    while(n--){
    	cin>>m;
    	k=cmp(1,65535,m);
		k=m-a[k-1];
		k=k%9;
		if(k)
    	cout<<k<<endl;
    	else cout<<"9"<<endl;
    	
    }
	
	return 0;
}
int cmp(int d,int b,int c){
	int mid=(d+b)/2;
	if(d<=b)
	{
		if(c>a[mid-1]&&c<=a[mid])
		     return mid;
        else if(c>a[mid]&&c<a[mid+1])
             return mid+1;
        else if(c>a[mid])
             cmp(mid+1,b,c);
        else cmp(d,mid-1,c);
 	}

}


posted @ 2015-11-02 20:11  (慎独)  阅读(157)  评论(0编辑  收藏  举报