hdu1412

一道水题!!!!

Problem Description
给你两个集合,要求{A} + {B}.
注:同一个集合中不会有两个相同的元素.
 

Input
每组输入数据分为三行,第一行有两个数字n,m(0<n,m<=10000),分别表示集合A和集合B的元素个数.后两行分别表示集合A和集合B.每个元素为不超出int范围的整数,每个元素之间有一个空格隔开.
 

Output
针对每组数据输出一行数据,表示合并后的集合,要求从小到大输出,每个元素之间有一个空格隔开.
 

Sample Input
1 2 1 2 3 1 2 1 1 2
 

Sample Output
1 2 3 1 2
 
代码:
  
#include<iostream>
#include <algorithm>
using namespace std;
int main(){
	int a[20005],n,m,i,j,k;
	while(cin>>n>>m){
		for(i=0;i<n+m;i++)
             cin>>a[i];
        sort(a,a+n+m);
        cout<<a[0]; 
        for(i=1;i<n+m;i++)
          if(a[i]!=a[i-1])
             cout<<" "<<a[i];
        cout<<endl;
	} 
	return 0;
} 


posted @ 2015-11-02 20:26  (慎独)  阅读(85)  评论(0编辑  收藏  举报