hdu 1587

Problem Description
As you know, Gardon trid hard for his love-letter, and now he's spending too much time on choosing flowers for Angel.
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers.
"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?


Input
Input have serveral test cases. Each case has two lines.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.


Output
For each case, print how many flowers Gardon can buy at most.
You may firmly assume the number of each kind of flower is enough.


Sample Input
2 5
2 3


Sample Output

2


代码:

#include<stdio.h>
int main(){
	int a,n,m,b,i;
	while((scanf("%d%d",&n,&m))!=EOF){
		b=100000000;
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			if(a<b) b=a;
		}
		printf("%d\n",m/b);
		
	}
	return 0;
} 


posted @ 2015-11-04 13:10  (慎独)  阅读(87)  评论(0编辑  收藏  举报