hdu 1019 n个数的最小公倍数

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.



Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output
105

10296


题目的意思:有多组测试,每组有n个数,求这n个数的最小公倍数;

代码:

#include <iostream>
using namespace std;
long long n,m,i,j,k,a;
int main() {
    cin>>n;
    while(n--){
        cin>>m;
        cin>>k;m=m-1;
        while(m--)
		{
            cin>>a;
            j=k*a;
            while(k!=0)
			{
             i=a%k;
             a=k;
             k=i;
            }
             k=j/a;   
        }
        cout<<k<<endl;
    }
    return 0;
}
思想是:是求两个数的最小公倍数延伸;比如现在有三个数,a,b,c;先求出a和b的最小公倍数d;然后再求d和a的最小公倍数e;e就是a,b,c的最小公倍数;



posted @ 2015-11-05 13:30  (慎独)  阅读(205)  评论(0编辑  收藏  举报