hdu 2438


Problem Description
Mr. West bought a new car! So he is travelling around the city.

One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.

Can Mr. West go across the corner?



Input
Every line has four real numbers, x, y, l and w.
Proceed to the end of file.


Output
If he can go across the corner, print "yes". Print "no" otherwise.


Sample Input
10 6 13.5 4
10 6 14.5 4


Sample Output
yes
no

思路:看懂题意后就会知道,这个是让找最值得;首先就的有函数关系式; 根据p到许仙的距离和角a有关系是:

f(a)=L*cos(a)-((x-w*cos(a))/tan(a)-w*sin(a))=L*cos(a)+(w-x*cos(a))/sin(a);

之后进行三分查找就行了;如果函数的最大值大于y值,不能通过;否则,通过;

如下图:
代码:
#include <stdio.h>
#include <string>
#include<iostream>
#include <cstring>
#include <iomanip>
#include <cmath>
#define pi 3.1415926
#include <algorithm>
using namespace std;	
double x,l,y,w,a,b,c;
double f(double t);
int main(){
	while(cin>>x>>y>>l>>w)
	{   a=0.0;
	    b=pi/2.0;
		double mid,mmid;
        while(b-a>1e-10){
           mid=(a+a+b)/3.0;
		   mmid=(mid+2*b)/3.0;
		   if(f(mid)>f(mmid))
		       b=mmid;
 	 	 else
		       a=mid;	
        }
        if(f(a)>y)
            cout<<"no"<<endl;
        else cout<<"yes"<<endl;		
	}
	return 0;
} 
double f(double t){
	return l*cos(t)+(w-x*cos(t))/(sin(t));
}


posted @ 2015-11-06 18:00  (慎独)  阅读(298)  评论(0编辑  收藏  举报