hdu 1856 More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.


Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)


Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.


Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8


Sample Output
4

2

一定要记得考虑n=0的情况;坑死我了!!!!!

这个题的意思就是让你找出包含元素最多的集合,输出该集合有几个元素!!!!

有是c++超时!!!c语言过!!!

代码:

#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm> 
using namespace std;
int a[10000002],b[10000002];
int find(int x)
{ int w=x;
  while(a[w]!=w)
     w=a[w];
  a[x]=w;
  return w;
} 
int cmp(int x,int y)
{
	int p=find(x);
	int q=find(y);
	if(q!=p)
	   a[p]=q;
}
int main()
{
	int n,i,j,k,A,B;
	while(scanf("%d",&n)!=EOF)
	{   j=1;
	   if(n==0)
	   {
	     b[0]=1;j=0;
	   }
	   if(j)
	   {for(i=1;i<=10000001;i++)
	        {a[i]=i;b[i]=0;}
	        b[0]=2;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&A,&B);
			b[A]=1;b[B]=1;
			cmp(A,B);
		}
		k=0;
		for(i=1;i<=10000001;i++)
		{
			if(a[i]!=i&&b[i])
			{
				k=find(a[i]);
				b[k]++; 
				
			}
			if(b[k]>b[0])
			     b[0]=b[k];
		}
	   }
	    
		printf("%d\n",b[0]);
	}
	return 0;
}


posted @ 2015-11-10 12:05  (慎独)  阅读(107)  评论(0编辑  收藏  举报