hdu 3635


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.


Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)


Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.


Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1


Sample Output
Case 1:
2 3 0
Case 2:
2 2 1

3 3 2

思路:题的大意明白了,就是当字符是Q时 判断A珠在哪个城市,输出该城市的编号,以及该城市现有多少龙珠,和A珠一共移动了多少次;


代码:

#include <iostream>
#include <stdio.h>
#include <cmath>
#include <string>
#include <algorithm>
using namespace std;
int a[10005],b[10005],c[10005],A,B,n;
void mcp()
{   int i;
    for(i=1;i<=n;i++)
    {a[i]=i;b[i]=1;c[i]=0;}
}
int find(int x)
{
    if(a[x]==x)return x;
    int t=a[x];
    a[x]=find(a[x]);
    c[x]+=c[t];
    return a[x];
}
void cmp(int x,int y)
{
    int i=find(x);
    int j=find(y);
    if(i!=j)
        {   a[i]=j;
            b[j]+=b[i];
            b[i]=0;
            c[i]=1;
        }
}
int main()
{
    int m,i,k,T,p,j,w;
    scanf("%d",&T);
        p=0;
        while(T--)
        {
            scanf("%d%d",&n,&m);
            mcp();
            char d[2];
            printf("Case %d:\n",++p);
            while(m--)
            {   scanf("%s",&d);
                if(d[0]=='T')
                    { scanf("%d%d",&A,&B);
                     cmp(A,B);
                    }
                  else 
                  { j=0;
                    scanf("%d",&A);
                    k=find(A);
                    printf("%d %d %d\n",k,b[k],c[A]);
                    } 
                
            }
        }
    
    return 0;
}




posted @ 2015-11-12 20:48  (慎独)  阅读(130)  评论(0编辑  收藏  举报