hdu 1263 水果

Problem Description
夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.


Input
第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.


Output
对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.


Sample Input
1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1


Sample Output
guangdong
|----pineapple(5)
|----sugarcane(1)
shandong

|----apple(3)

爱上结构体了!!!!!!

注意输出格式就行了!!!!!!

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <iomanip>
#include <algorithm>
using namespace std;

struct dot 
{
	string s,t;
	int n;
}st[1000];
int cmp(dot x,dot y)
{
	if(x.t!=y.t)
	   return x.t<y.t;
    else 
       return x.s<y.s;
}
int main()
{   int i,j,k,m,T;
    cin>>T;
    k=0;
	while(T--)
	{cin>>m;
	    for(i=0;i<m;i++)
		   cin>>st[i].s>>st[i].t>>st[i].n;
        sort(st,st+m,cmp);
	
		for(i=m-1;i>0;i--)
	    {
		 if(st[i].s==st[i-1].s&&st[i].t==st[i-1].t)
		      st[i-1].n+=st[i].n;
	    }
        if(k)cout<<endl;
        cout<<st[0].t<<endl<<"   |----"<<st[0].s<<"("<<st[0].n<<")"<<endl;
	    for(i=1;i<m;i++)
	    { if(st[i].t==st[i-1].t&&st[i].s!=st[i-1].s)
	         cout<<"   |----"<<st[i].s<<"("<<st[i].n<<")"<<endl;
          else if(st[i].t!=st[i-1].t)
             cout<<st[i].t<<endl<<"   |----"<<st[i].s<<"("<<st[i].n<<")"<<endl;   
	    }
	      	
 	    k++;
	} 
return 0;	
}


posted @ 2015-11-13 13:54  (慎独)  阅读(632)  评论(0编辑  收藏  举报