hdu 1196


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


Output
For each A in the input, output a line containing only its lowest bit.


Sample Input
26
88
0


Sample Output
2
8

啥也不说了!!!水题!!!!

代码:

#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <iomanip> 

using namespace std;
int lowbit(int x)
{
	return x&(-x);
}
int main()
{   int n;
      while(cin>>n&&n)
      {
      	cout<<lowbit(n)<<endl;
      }
      return 0;
}


posted @ 2015-11-16 21:40  (慎独)  阅读(120)  评论(0编辑  收藏  举报