hdu 2642 Stars

Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.


Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.


Output
For each query,output the number of bright stars in one line.


Sample Input
5
B 581 145
B 581 145
Q 0 600 0 200
D 581 145
Q 0 600 0 200


Sample Output
1

0

二维树状数组

代码:

#include <iostream>
#include <algorithm>
#include <cstring> 
using namespace std;
int a[1005][1005],c[1005][1005];
int lowbit(int x)
{
	return x&(-x);
}
int Sum(int i,int j)
{   int sum=0,k,p;
	for(k=i;k>0;k=k-lowbit(k))
	  for(p=j;p>0;p=p-lowbit(p))
	    sum+=c[k][p];
	return sum;
}
void change(int i,int j,int x)
{       int k,p;
		for(k=i;k<=1004;k=k+lowbit(k))
	      for(p=j;p<=1004;p=p+lowbit(p))
	          c[k][p]+=x;
}
int main()
{
	int i,j,k,n,m,x,y;
	char ch;
	    while(cin>>n)
	    {
	     m=n;
		 memset(a,0,sizeof(a));
		 memset(c,0,sizeof(c));
		 while(n--)
		  {
			cin>>ch;
			if(ch=='B'||ch=='D')
			{
				cin>>x>>y;
				x++;y++;
				if(ch=='B'&&a[x][y]==0)
				    {
					  change(x,y,1); 
					  a[x][y]=1;
				    }
			    
                if(ch=='D'&&a[x][y]==1)
                    { 
					  change(x,y,-1);
					  a[x][y]=0;
                    }
		    }
            else 
		    {	int x1,x2,y1,y2;
		        cin>>x1>>x2>>y1>>y2;
				if(x1>x2)
			        swap(x1,x2);
			
				if(y1>y2)
					swap(y1,y2);
				cout<<Sum(x2+1,y2+1)+Sum(x1,y1)-Sum(x1,y2+1)-Sum(x2+1,y1)<<endl;
		    }
		   
		  } 
	    }
	return 0;
}


posted @ 2015-11-19 21:33  (慎独)  阅读(162)  评论(0编辑  收藏  举报