hdu 2689 Sort it

Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.


Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.


Output
For each case, output the minimum times need to sort it in ascending order on a single line.


Sample Input
3
1 2 3
4
4 3 2 1


Sample Output
0

6

给你一个无序数列,让你由小到大排序,看一公交换多少次;

代码:

 

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <iomanip>
using namespace std;
int main()
{
	int m,n,i,j,k,p,q,a[1005];
	while(cin>>n)
	{
		for(i=0;i<n;i++)
		    cin>>a[i];
        k=0;
        for(i=0;i<n-1;i++)
           for(j=i+1;j<n;j++)
             if(a[i]>a[j])
                {
                	swap(a[i],a[j]);
                	k++;
                }
        cout<<k<<endl;
	}
	return 0;
	
}

posted @ 2015-11-20 11:55  (慎独)  阅读(111)  评论(0编辑  收藏  举报