hdu 素数环

算法:搜索

题意:相邻的两个数之和是素数,别忘了最后一个,和第一个

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.




Input
n (0 < n < 20).


Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.


Sample Input
6
8


Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

代码:

#include <iostream>
#include <string>
#include <algorithm>
#include <iomanip>
#include <cstring>
using namespace std;
int a[30],b[45],n,m,c[30];
void cmp()
{   memset(b,1,sizeof(b));
    b[1]=b[0]=0;
	for(int i=2;i<=22;i++)
	{
		for(int j=2*i;j<45;j=j+i)
		    b[j]=0;
	}
}
void dfs(int x,int k)
{
	if(k==n&&b[c[0]+c[n-1]])
	{
		for(int i=0;i<n;i++)
		{
			if(i)cout<<" ";
			cout<<c[i];
		}
		cout<<endl;
	}
	else 
	{
		for(int i=2;i<=n;i++)
		{
			if(!a[i]&&b[i+c[k-1]])
			{
				a[i]=1;
				c[k]=i;
				dfs(n,k+1);
				a[i]=0;
			}
		}
	}
} 
int main()
{
	int i,j=0;
	cmp();
	while(cin>>n)
	{
		for(i=1;i<=n;i++)
		   a[i]=0;
		c[0]=1;
		cout<<"Case "<<++j<<":"<<endl;
		dfs(n,1);
		cout<<endl;
	}
	return 0;
}


posted @ 2015-12-11 10:47  (慎独)  阅读(172)  评论(0编辑  收藏  举报