uva Fire!

算法:BFS

Joe works in a maze. Unfortunately, portions of the maze have
caught on fire, and the owner of the maze neglected to create a fire
escape plan. Help Joe escape the maze.
Given Joe’s location in the maze and which squares of the maze
are on fire, you must determine whether Joe can exit the maze before
the fire reaches him, and how fast he can do it.
Joe and the fire each move one square per minute, vertically or
horizontally (not diagonally). The fire spreads all four directions
from each square that is on fire. Joe may exit the maze from any
square that borders the edge of the maze. Neither Joe nor the fire
may enter a square that is occupied by a wall.
Input
The first line of input contains a single integer, the number of test
cases to follow. The first line of each test case contains the two
integers R and C, separated by spaces, with 1 ≤ R, C ≤ 1000. The
following R lines of the test case each contain one row of the maze. Each of these lines contains exactly
C characters, and each of these characters is one of:
• #, a wall
• ., a passable square
• J, Joe’s initial position in the maze, which is a passable square
• F, a square that is on fire
There will be exactly one J in each test case.
Output
For each test case, output a single line containing ‘IMPOSSIBLE’ if Joe cannot exit the maze before the
fire reaches him, or an integer giving the earliest time Joe can safely exit the maze, in minutes.
Sample Input
2
4 4
####
#JF#
#..#
#..#
3 3
###
#J.
#.F
Sample Output
3
IMPOSSIBLE

注意开始有多个火堆;

代码:

#include <iostream>
#include <cstring>
#include <iomanip>
#include <stdio.h>
#include <queue>
#include <algorithm>
#define INF 100000000
using namespace std;
char ch[1005][1005];
int b[1005][1005],c[1004][1005],qq,cnt,d[1005][2];
int n,m,a[4][2]={-1,0,0,-1,0,1,1,0},p,q;
struct dot
{
    int x,y,step;	
};
void bfs()
{   memset(c,0,sizeof(c));
	queue<dot>que;
	dot cur,loer;
	for(int i=0;i<cnt;i++)
	{
	   cur.x=d[i][0];
	   cur.y=d[i][1];
	   cur.step=0;
	   b[cur.x][cur.y]=0;
	   c[cur.x][cur.y]=1;
	   que.push(cur);
	}
	while(que.size())
	{
		loer=que.front();
		que.pop();
		for(int i=0;i<4;i++)
		{
			int dx,dy;
			dx=loer.x+a[i][0];
			dy=loer.y+a[i][1];
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&ch[dx][dy]=='.'&&!c[dx][dy])
	        {
	        	cur.x=dx;cur.y=dy;cur.step=loer.step+1;
	        	b[dx][dy]=min(cur.step,b[dx][dy]);
				c[dx][dy]=1;
	        	que.push(cur);
			} 	
		}
	}
}
void bsf()
{   memset(c,0,sizeof(c));
	queue<dot>que;
	dot cur,loer;
	cur.x=p;
	cur.y=q;
	cur.step=0;
	c[p][q]=1;
	que.push(cur);
	while(que.size())
	{
		loer=que.front();
		que.pop();
		if(loer.x==0||loer.x==n-1||loer.y==0||loer.y==m-1)
		{   qq=1;
			cout<<loer.step+1<<endl;
			break;
		}
		for(int i=0;i<4;i++)
		{
			int dx,dy;
			dx=loer.x+a[i][0];
			dy=loer.y+a[i][1];
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&ch[dx][dy]=='.'&&!c[dx][dy]&&b[dx][dy]>loer.step+1)
			{
				cur.x=dx;
				cur.y=dy;
				cur.step=loer.step+1;
				c[dx][dy]=1;
				que.push(cur);
			}
		}
	}
}
int main()
{
	int T,i,j,k;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		cnt=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				cin>>ch[i][j];
				b[i][j]=INF;
				if(ch[i][j]=='J')
				{
				   p=i;q=j;
				   ch[i][j]='.';
				}
				else if(ch[i][j]=='F')
				{
					d[cnt][0]=i;
					d[cnt++][1]=j;
				}
			}
		}
		qq=0;

		bfs();
		bsf();
		if(qq==0) cout<<"IMPOSSIBLE"<<endl;
	}
	return 0;
}
 


posted @ 2016-01-03 18:12  (慎独)  阅读(184)  评论(0编辑  收藏  举报