cigarettes

 

cigaretteshttp://acm.nyist.net/JudgeOnline/problem.php?pid=94

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
 
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?

 
输入
First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
#include<stdio.h>
int main()
{
 int n;
 scanf("%d",&n);
 while(n--)
 {
  int m,t,sum=0;
  scanf("%d %d",&m,&t);
  sum+=m;
  while(m>=t)
  {
   sum+=m/t;
   m=m/t+m%t;
  }
  printf("%d\n",sum);
 }
 return 0;
}
代码很简单,就是累加问题。做好循环的问题就能解决它了。
posted @ 2013-08-01 08:22  王莜轩  阅读(182)  评论(0编辑  收藏  举报