大数问题

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 165469    Accepted Submission(s): 31614


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110 代码如下:


#include<stdio.h>
#include<string.h>
#define M 1000
int a1[M+10];
int b1[M+10];
//int c[M+10];
char a[M+10];
char b[M+10];
int main()
{
	int k,n;		
	int i,j,t;
	int n1,n2;
	scanf("%d",&n);
	for(k=1;k<=n;k++)
	{
		scanf("%s %s",a,b);
		memset(a1,0,sizeof(a1));
		memset(b1,0,sizeof(b1));
	//	memset(c,0,sizeof(c));
		n1=strlen(a);
	/*	for(i=0;i<n1;i++)
			c[i]=a[i]-'0';*/
		for(j=0,i=n1-1;i>=0;i--)
		{
			a1[j]=a[i]-'0';
			j++;
		}
		n2=strlen(b);
		for(j=0,i=n2-1;i>=0;i--)
		{
			b1[j]=b[i]-'0';
			j++;
		}
		for(i=0;i<M;i++)
		{
			a1[i]+=b1[i];
			if(a1[i]>=10)
			{
				a1[i]-=10;
				a1[i+1]++;
			}
		}
		printf("Case %d:\n%s + %s = ",k,a,b);
		for(i=M;(i>=0)&&(a1[i]==0);i--);
		if(i>=0)
		for(;i>=0;i--)
			printf("%d",a1[i]);
		else
			printf("0");
		if(k==n)
			printf("\n");
		else
			printf("\n\n");
	}
	return 0;
}

 


 

posted @ 2013-07-29 11:46  王莜轩  阅读(228)  评论(0编辑  收藏  举报