Sum Problem

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 201094    Accepted Submission(s): 48459

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
 

 

Author
DOOM III
 
 
程序代码:
 
 
#include<stdio.h>
main()
{
    int a,sum,i;
    while(scanf("%d",&a)!=EOF)
    {
        sum=0;
        for(i=1;i<=a;i++)
            sum+=i;
        printf("%d\n\n",sum);
    }
}
posted @ 2013-03-21 13:10  王文城  阅读(155)  评论(0编辑  收藏  举报