hdu 1312 Red and Black

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#. .#.
#.###.#. .#.
#..@#.#. .#.
#####.#.
.#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

 

Sample Output
45
59
6
13

 

#include<iostream>
using namespace std;
char mapp[65][65];
int m,n,k=0,c=0,d=0;
void dfs(int x,int y)
{
    if(mapp[x][y]=='#'||x<0||y<0||x>=m||y>=n)
    {
        return;
    } 
    mapp[x][y]='#';
    dfs(x+1,y);
    dfs(x-1,y);
    dfs(x,y+1);
    dfs(x,y-1);
}
int main()
{
    int i,j,k; 
    while(cin>>n>>m)
    {
        c=0;
        d=0;
        if(m==0&&n==0)
        break;
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                cin>>mapp[i][j];
            }    
        }
        for(i=0;i<m;i++)
        for(j=0;j<n;j++)
        {
            if(mapp[i][j]=='#')
            c++;
        }
        k=0;
        for(i=0;i<m;i++)
        {
                for(j=0;j<n;j++)
            {
                if(mapp[i][j]=='@')
                {
                    mapp[i][j]='.';
                    dfs(i,j);
                }
            }
        }
        for(i=0;i<m;i++)
        for(j=0;j<n;j++)
        {
            if(mapp[i][j]=='#')
            d++;
        }
        cout<<d-c<<endl;
    }
    return 0;
}

 

posted @ 2016-04-16 21:04  俺叫王梦涵  阅读(140)  评论(0编辑  收藏  举报