hdu 2099 整除的尾数

Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 

 

Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

 

Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 

 

Sample Input
200 40
1992 95
0 0
 

 

Sample Output
00 40 80
15
 
本题需要注意的是输出方式,我才用了%02d,还要注意注后输出没有空格的问题。
#include<stdio.h>
int main()
{
    int a,b,n;
    while(~scanf("%d%d",&a,&b)&&(a||b))
    {
        a=a*100;
        for(int i=0,j=0;i<100;i++)
        {
            
            if((a+i)%b==0)
            {
                    j++;
                       if(j!=1)
                       printf(" ");
                    printf("%02d",i);
            }
            
        }
                    printf("\n");
    }    
} 

 

 

posted @ 2015-12-31 10:31  俺叫王梦涵  阅读(130)  评论(0编辑  收藏  举报