1100 Mars Numbers(20 分)

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13
复制代码
#include<iostream>
#include<string>
#include<map>
using namespace std;
string numTostr[170];
map<string,int> strTonum;
string unitDigit[13]={
    "tret", "jan", "feb","mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"
    };
string tenDigit[13] = {
   "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"
};

void init(){
    for(int i = 0; i < 13; i++){
        strTonum[unitDigit[i]] = i;
        numTostr[i] = unitDigit[i];
        strTonum[tenDigit[i]] = i * 13;
        numTostr[i * 13] = tenDigit[i];
    }
    for(int i = 1; i < 13; i++){
        for(int j = 1; j < 13; j++){
            string str = tenDigit[i] + " " + unitDigit[j];
            numTostr[i * 13 + j] = str;
            strTonum[str] = i * 13 + j;
        }
    }
}

int main(){
    init();
    int n;
    scanf("%d%*c",&n);
    while(n--){
        string str;
        getline(cin,str);
        if(str[0] >= '0' && str[0] <= '9'){
            int num = 0;
            for(int i = 0 ; i < str.length(); i++){
                num = num * 10 + (str[i] - '0');
            }
            cout << numTostr[num] << endl;
        }else{
            cout << strTonum[str] << endl;
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(196)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示