1093 Count PAT's(25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 1 characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2
复制代码
#include<cstdio>
#include<cstring>
const int maxn = 100010;
const int MOD = 1000000007;
char str[maxn];
int leftNumP[maxn] = {0};
int main(){
    fgets(str,maxn,stdin);
    int len = strlen(str);
    for(int i = 0; i < len; i++){
        if(i > 0){
            leftNumP[i] = leftNumP[i-1];
        }
        if(str[i] == 'P'){
            leftNumP[i]++;
        }
    }
    int ans = 0,rightNumT = 0;
    for(int i = len - 1; i >= 0; i--){
        if(str[i] == 'T'){
            rightNumT++;
        }else if(str[i] == 'A'){
            ans = (ans + rightNumT * leftNumP[i]) % MOD;
        }
    }
    printf("%d\n",ans);
    return 0;
}
复制代码

 

posted @   王清河  阅读(174)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示