1049 Counting Ones (30)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30^).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5
复制代码
#include<cstdio>
int main(){
    int n;
    scanf("%d",&n);
    int a = 1,left,now,right,ans = 0;
    while(n/a){
        left = n / (a*10);
        right = n % a;
        now = n / a % 10;
        if(now == 0) ans += left*a;
        else if(now == 1) ans += left*a + right + 1;
        else ans += (left+1)*a;
        a *= 10; 
    }
    printf("%d",ans);
    return 0;
}
复制代码

 

posted @   王清河  阅读(107)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示