1049 Counting Ones (30)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30^).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5
#include<cstdio>
int main(){
    int n;
    scanf("%d",&n);
    int a = 1,left,now,right,ans = 0;
    while(n/a){
        left = n / (a*10);
        right = n % a;
        now = n / a % 10;
        if(now == 0) ans += left*a;
        else if(now == 1) ans += left*a + right + 1;
        else ans += (left+1)*a;
        a *= 10; 
    }
    printf("%d",ans);
    return 0;
}

 

posted @ 2018-08-22 20:01  王清河  阅读(103)  评论(0编辑  收藏  举报