1044 Shopping in Mars (25)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M\$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M\$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M\$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).\

  1. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).\
  2. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).\

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10^5^), the total number of diamonds on the chain, and M (<=10^8^), the amount that the customer has to pay. Then the next line contains N positive numbers D~1~ ... D~N~ (D~i~<=10^3^ for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that D~i~ + ... + D~j~ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that D~i~ + ... + D~j~ > M with (D~i~ + ... + D~j~ - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5
复制代码
#include<cstdio>
const int N = 100010;
int sum[N];
int n,s,nearS = 100000000;

int upper_bound(int left,int right,int x){
    int mid;
    while(left < right){
        mid = (left + right)/2;
        if(sum[mid] > x){
            right = mid;
        }else{
            left = mid + 1;
        }
    }
    return left;
}

int main(){
    scanf("%d%d",&n,&s);
    sum[0] = 0;
    for(int i = 1; i <= n; i++){
        scanf("%d",&sum[i]);
        sum[i] += sum[i-1];
    }
    for(int i = 1; i <= n; i++){
        int j = upper_bound(i,n+1,sum[i-1]+s);
        if(sum[j-1] - sum[i-1] == s){
            nearS = s;
            break;
        }else if(j <= n && sum[j] - sum[i-1] < nearS){
            nearS = sum[j] - sum[i-1];
        }
    }
    for(int i = 1 ; i <= n ; i++){
        int j = upper_bound(i,n+1,sum[i-1]+nearS);
        if(sum[j - 1] - sum[i - 1] == nearS){
            printf("%d-%d\n",i,j-1);
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(94)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示