1025 PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
复制代码
//18.8.11
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct student{
    char id[15]; //错误1 
    int score;
    int location_number;
    int local_rank;
}stu[30010];

bool cmp(student a,student b){
    if(a.score != b.score) return a.score > b.score;
    else return strcmp(a.id,b.id) < 0;
}

int main(){
    int n,k,num = 0;
    scanf("%d",&n);
    for(int i = 1 ; i <= n ; i++){
        scanf("%d",&k);
        for(int j = 0; j < k ; j++){
            scanf("%s %d",stu[num].id,&stu[num].score);
            stu[num].location_number = i;
            num++;
        }
        //(0,4)(5,8) 两次排序 
        sort(stu + num - k , stu + num ,cmp);
        stu[num - k].local_rank = 1;  //stu[0],stu[5] ,num = 5,9,k = 5,4
        for(int j = num - k + 1; j < num ; j++){  //j = 1 < 5, = 6 < 9
            if(stu[j].score != stu[j - 1].score){
                stu[j].local_rank = j + 1 - (num - k);
            }else{
                stu[j].local_rank = stu[j - 1].local_rank;
            }
        }
    }
    printf("%d\n",num);
    sort(stu,stu+num,cmp);
    int r = 1;
    for(int i = 0; i < num ; i++){
        if(i > 0 && stu[i].score != stu[i - 1].score){
            r = i + 1;
        }
        printf("%s %d %d %d\n",stu[i].id,r,stu[i].location_number,stu[i].local_rank);
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(129)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示