1057 Stack (30)

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 10^5^). Then N lines follow, each contains a command in one of the following 3 formats:

Push key\ Pop\ PeekMedian

where key is a positive integer no more than 10^5^.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
复制代码
#include<cstdio>
#include<stack>
#include<cstring>
using namespace std;
const int maxn = 100010;
const int sqrN = 351;

stack<int> st;
int block[maxn],table[maxn];

void peekMedian(int k){
    int sum = 0;
    int idx = 0;
    while(sum + block[idx] < k){
        sum += block[idx++];
    }
    int num = idx * sqrN;
    while(sum + table[num] < k){
        sum += table[num++];
    }
    printf("%d\n",num);
}

void Push(int x){
    st.push(x);
    block[x/sqrN]++;
    table[x]++;
}
void Pop(){
    int t = st.top();
    st.pop();
    block[t/sqrN]--;
    table[t]--;
    printf("%d\n",t);
}

int main(){
    int n,x;
    memset(block,0,sizeof(block));
    memset(table,0,sizeof(table));
    scanf("%d",&n);
    char cmd[20];
    for(int i = 0; i < n; i++){
        scanf("%s",cmd);
        if(strcmp(cmd,"Push") == 0){
            scanf("%d",&x);
            Push(x);
        }else if(strcmp(cmd,"Pop") == 0){
            if(st.empty() == true){
                printf("Invalid\n");
            }else{
                Pop();
            }
        }else{
            if(st.empty() == true){
                printf("Invalid\n");
            }else{
                int k = st.size();
                if(k % 2 == 0) k = k/2;
                else k = (k+1)/2;
                peekMedian(k);
            }
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(820)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示