1008 Elevator (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41
复制代码
#include<cstdio>
int main(){
    int n,k,f = 0, sum = 0;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&k);
        if(k > f){
            sum += (k-f)*6+5;
            f = k;
        }else{
            sum += (f-k)*4+5;
            f= k;
        }
    }
    printf("%d",sum);
    return 0;
} 
复制代码

 20190718

复制代码
#include<cstdio>

int main()
{
     int curr = 0;
    int k;
    int next;
    scanf("%d",&k);
    int sum = 0;
    for(int i = 0; i < k; i++)
    {
         scanf("%d",&next);
        if(next > curr)
        {
             sum += (next - curr) * 6 + 5;    
        }    
        else
        {
            sum += (curr - next) * 4 + 5;
        }
        curr = next;
    }    
    printf("%d",sum);
    return 0;
} 
复制代码

 

posted @   王清河  阅读(112)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示