1099 Build A Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42
 
复制代码
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn = 110;
struct Node{
    int data;
    int lchild,rchild;
}node[maxn];
int n,in[maxn],num = 0;

void inOrder(int root){
    if(root == -1) return;
    inOrder(node[root].lchild);
    node[root].data = in[num++];
    inOrder(node[root].rchild);
}

void BFS(int root){
    queue<int> Q;
    Q.push(root);
    int num = 0;
    while(!Q.empty()){
        int now = Q.front();
        Q.pop();
        printf("%d",node[now].data);
        num++;
        if(num < n) printf(" ");
        if(node[now].lchild != -1) Q.push(node[now].lchild);
        if(node[now].rchild != -1) Q.push(node[now].rchild);
    }
}

int main(){
    int lchild,rchild;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d%d",&lchild,&rchild);
        node[i].lchild = lchild;
        node[i].rchild = rchild;
    }
    for(int i = 0; i < n; i++){
        scanf("%d",&in[i]);
    }
    sort(in,in+n);
    inOrder(0);
    BFS(0);
    return 0;
} 
复制代码

 

posted @   王清河  阅读(148)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示