1043 Is It a Binary Search Tree (25)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO
复制代码
#include<cstdio>
#include<vector>
using namespace std;
struct Node{
    int data;
    Node* left, *right;
};
void insert(Node* &root,int data){
    if(root == NULL){
        root = new Node;
        root -> data = data;
        root -> left = root -> right = NULL;
        return;
    }
    if(data < root -> data) insert(root -> left,data);
    else  insert(root -> right,data);
}

void preOrder(Node* root,vector<int>& vi){ //Node* &root  该&不能缺少

    if(root == NULL) return;

    vi.push_back(root -> data);
    preOrder(root -> left,vi);
    preOrder(root -> right,vi);
}

void preOrderMirror(Node* root, vector<int> &vi){
    if(root == NULL) return;
    vi.push_back(root -> data);
    preOrderMirror(root -> right,vi);
    preOrderMirror(root -> left,vi);
}

void postOrder(Node* root,vector<int> &vi){
    if(root == NULL)  return;
    postOrder(root -> left,vi);
    postOrder(root -> right,vi);
    vi.push_back(root -> data);
}

void postOrderMirror(Node* root,vector<int> &vi){
    if(root == NULL)  return;
    postOrderMirror(root ->right,vi);
    postOrderMirror(root -> left,vi);
    vi.push_back(root -> data);
}

vector<int> original,pre,preM,post,postM;
int main(){
    Node *root = NULL;
    int n,data;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&data);
        original.push_back(data);
        insert(root,data);
    }
    preOrder(root,pre);
    preOrderMirror(root,preM);
    postOrder(root,post);
    postOrderMirror(root,postM);

    if(original == pre){
        printf("YES\n");
        for(int i = 0; i < post.size(); i++){
            printf("%d",post[i]);
            if(i < post.size() - 1) printf(" ");
            
        }
    }else if(original == preM){
        printf("YES\n");
        for(int i = 0; i < postM.size(); i++){
            printf("%d",postM[i]);
            if(i < postM.size() - 1) printf(" ");
        }
    }else{
      printf("NO");
    }
    return 0;
} 
复制代码

 

posted @   王清河  阅读(131)  评论(0编辑  收藏  举报
编辑推荐:
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
· 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
阅读排行:
· DeepSeek 开源周回顾「GitHub 热点速览」
· 物流快递公司核心技术能力-地址解析分单基础技术分享
· .NET 10首个预览版发布:重大改进与新特性概览!
· AI与.NET技术实操系列(二):开始使用ML.NET
· 单线程的Redis速度为什么快?
点击右上角即可分享
微信分享提示