1063. Set Similarity (25)

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%
复制代码
#include<cstdio>
#include<set>
using namespace std;
set<int> st[51];
void compre(int x,int y){
    int totalNum = st[y].size(),sameNum = 0;
    for(set<int>::iterator it = st[x].begin(); it != st[x].end(); it++){
        if(st[y].find(*it) != st[y].end()) sameNum++;
        else totalNum++;
    }
    printf("%.1f%%\n",sameNum*100.0/totalNum);
}


int main(){
    int n,m,v,k,st1,st2;
    scanf("%d",&n);
    for(int i = 1; i <= n; i++){
        scanf("%d",&m);
        for(int j = 0 ; j < m; j++){
            scanf("%d",&v);
            st[i].insert(v);
        }
    }
    scanf("%d",&k);
    for(int i = 0; i < k; i++){
        scanf("%d%d",&st1,&st2);
        compre(st1,st2);
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(90)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示