1096. Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7
复制代码
#include<cstdio>
#include<cmath>
typedef long long ll;
int main(){
    ll n;
    scanf("%lld",&n);
    ll sqr = (int)sqrt(1.0*n),ansI=0,ansLen = 0;
    for(ll i = 2; i <= sqr; i++){
        ll temp = 1,j = i;
        while(1){
            temp *= j;
            if(n % temp != 0) break;
            if(j - i + 1 > ansLen){
                ansI = i;
                ansLen = j - i + 1;
            }
            j++;
        }
    }
    if(ansLen == 0) printf("1\n%lld",n);
    else{
        printf("%lld\n",ansLen);
        for(ll i = 0; i < ansLen; i++){
            printf("%lld",ansI+i);
            if(i<ansLen - 1) printf("*");
        }
    }
    return 0;
}
复制代码

 

posted @   王清河  阅读(104)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示