1085. Perfect Sequence (25)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
复制代码
#include<cstdio>                                    
#include<algorithm>                                 
using namespace std;                                
int n,p,a[100010];                                  
                                                    
int binarySearch(int i, long long x){               
    if(a[n - 1] <= x) return n;                        
    int l = i + 1, r = n - 1;                          
    while(l < r){                                      
        int mid = (r + l) / 2;                            
        if(a[mid] <= x){                                  
            l = mid + 1;                                     
        }else{                                            
            r = mid;                                         
        }                                                 
    }                                                  
    return l;                                          
}                                                   
                                                    
int main(){                                         
                                                       
    scanf("%d%d",&n,&p);                               
    for(int i = 0; i < n; i++){                        
        scanf("%d",&a[i]);                                
    }                                                  
    sort(a,a+n);                                       
    int ans = 1;                                       
    for(int i = 0; i < n; i++){                        
                                                          
        int j = binarySearch(i,(long long)a[i]*p);        
        ans = max(ans, j - i);                            
    }                                                  
    printf("%d\n",ans);                                
    return 0;                                          
}                                                   
复制代码

 

复制代码
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int n,p,a[maxn];
int main(){
    scanf("%d%d",&n,&p);
    for(int i = 0; i < n; i++){
        scanf("%d",&a[i]);
    }
    sort(a,a+n);
    int i = 0, j = 0,count = 1;
    while(i < n && j < n){
        while(j < n && (long long)a[i]*p >= a[j]){
            count = max(count,j - i + 1);
             j++;
        }
        i++;
    }
    printf("%d",count);
    return 0;
}
复制代码

 

posted @   王清河  阅读(160)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
阅读排行:
· 物流快递公司核心技术能力-地址解析分单基础技术分享
· .NET 10首个预览版发布:重大改进与新特性概览!
· 单线程的Redis速度为什么快?
· 展开说说关于C#中ORM框架的用法!
· Pantheons:用 TypeScript 打造主流大模型对话的一站式集成库
点击右上角即可分享
微信分享提示