1070. Mooncake (25)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45
复制代码
#include<cstdio>
#include<algorithm>
using namespace std;
struct mooncake{
    double store;  //存量 
    double total;   //总价格 
    double price;   // 单价 
}Moon[1010];
bool cmp(mooncake a,mooncake b){
    return a.price > b.price;
}
int main(){
    int n;
    double d;
    scanf("%d%lf",&n,&d);
    for(int i = 0; i < n; i++){
        scanf("%lf",&Moon[i].store);
    }
    for(int i = 0; i < n; i++){
        scanf("%lf",&Moon[i].total);
        Moon[i].price = Moon[i].total / Moon[i].store;
    }
    sort(Moon,Moon+n,cmp);
    double totalPrice = 0;
    for(int i = 0; i < n; i++){
        if(Moon[i].store <= d){
            totalPrice += Moon[i].total;
            d -= Moon[i].store;
        }else{
            totalPrice += d*Moon[i].price;
            break;
        }
    }
    printf("%.2f\n",totalPrice);
    return 0;
}
复制代码

 

posted @   王清河  阅读(169)  评论(0编辑  收藏  举报
编辑推荐:
· 基于Microsoft.Extensions.AI核心库实现RAG应用
· Linux系列:如何用heaptrack跟踪.NET程序的非托管内存泄露
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
阅读排行:
· 震惊!C++程序真的从main开始吗?99%的程序员都答错了
· 别再用vector<bool>了!Google高级工程师:这可能是STL最大的设计失误
· 单元测试从入门到精通
· 【硬核科普】Trae如何「偷看」你的代码?零基础破解AI编程运行原理
· 上周热点回顾(3.3-3.9)
点击右上角即可分享
微信分享提示